import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s+<span.+lj:user=\"\n"
+ "([-\\w]{1,15})\n"
+ "\".+<b>\n"
+ "([-\\w\\s]+)\n"
+ "<\\/b>.+ —\\s\n"
+ "([-\\.\\w\\s]+)\n"
+ "<\\/div>$";
final String string = " <div>\n"
+ " <span class=\"ljuser i-ljuser i-ljuser-type-P \" data-ljuser=\"canonf\" lj:user=\"canonf\" ><a href=\"http://canonf.livejournal.com/profile\" target=\"_self\" class=\"i-ljuser-profile\" ><img class=\"i-ljuser-userhead\" src=\"http://l-stat.livejournal.net/img/userinfo.gif?v=17080?v=134.3\" /></a><a href=\"http://canonf.livejournal.com/\" class=\"i-ljuser-username\" target=\"_self\" ><b>canonf</b></a></span> — Растоптать от души.\n"
+ " </div>\n"
+ " <div>\n"
+ " <span class=\"ljuser i-ljuser i-ljuser-type-I \" data-ljuser=\"ext_2056646\" lj:user=\"ext_2056646\" ><a href=\"http://www.livejournal.com/profile?userid=65329483&t=I\" target=\"_self\" class=\"i-ljuser-profile\" ><img class=\"i-ljuser-userhead\" src=\"http://l-stat.livejournal.net/img/icons/facebook-16.png?v=29916?v=134.3\" /></a><a href=\"http://www.facebook.com/profile.php?id=100001197014517\" class=\"i-ljuser-username\" target=\"_self\" ><b>Летающий Котёнок</b></a></span> — Растоптать от души.\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}