const regex = /^\s+<span.+lj:user="
([-\w]{1,15})
".+<b>
([-\w\s]+)
<\/b>.+ —\s
([-\.\w\s]+)
<\/div>$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s+<span.+lj:user="
([-\\w]{1,15})
".+<b>
([-\\w\\s]+)
<\\\/b>.+ —\\s
([-\\.\\w\\s]+)
<\\\/div>$', 'gmu')
const str = ` <div>
<span class="ljuser i-ljuser i-ljuser-type-P " data-ljuser="canonf" lj:user="canonf" ><a href="http://canonf.livejournal.com/profile" target="_self" class="i-ljuser-profile" ><img class="i-ljuser-userhead" src="http://l-stat.livejournal.net/img/userinfo.gif?v=17080?v=134.3" /></a><a href="http://canonf.livejournal.com/" class="i-ljuser-username" target="_self" ><b>canonf</b></a></span> — Растоптать от души.
</div>
<div>
<span class="ljuser i-ljuser i-ljuser-type-I " data-ljuser="ext_2056646" lj:user="ext_2056646" ><a href="http://www.livejournal.com/profile?userid=65329483&t=I" target="_self" class="i-ljuser-profile" ><img class="i-ljuser-userhead" src="http://l-stat.livejournal.net/img/icons/facebook-16.png?v=29916?v=134.3" /></a><a href="http://www.facebook.com/profile.php?id=100001197014517" class="i-ljuser-username" target="_self" ><b>Летающий Котёнок</b></a></span> — Растоптать от души.
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}