import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"""
^\s+<span.+lj:user="
([-\w]{1,15})
".+<b>
([-\w\s]+)
<\/b>.+ —\s
([-\.\w\s]+)
<\/div>$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
<div>
<span class="ljuser i-ljuser i-ljuser-type-P " data-ljuser="canonf" lj:user="canonf" ><a href="http://canonf.livejournal.com/profile" target="_self" class="i-ljuser-profile" ><img class="i-ljuser-userhead" src="http://l-stat.livejournal.net/img/userinfo.gif?v=17080?v=134.3" /></a><a href="http://canonf.livejournal.com/" class="i-ljuser-username" target="_self" ><b>canonf</b></a></span> — Растоптать от души.
</div>
<div>
<span class="ljuser i-ljuser i-ljuser-type-I " data-ljuser="ext_2056646" lj:user="ext_2056646" ><a href="http://www.livejournal.com/profile?userid=65329483&t=I" target="_self" class="i-ljuser-profile" ><img class="i-ljuser-userhead" src="http://l-stat.livejournal.net/img/icons/facebook-16.png?v=29916?v=134.3" /></a><a href="http://www.facebook.com/profile.php?id=100001197014517" class="i-ljuser-username" target="_self" ><b>Летающий Котёнок</b></a></span> — Растоптать от души.
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)