const regex = /{{([^},]+)(?:,([^}]+))?}}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{([^},]+)(?:,([^}]+))?}}', 'g')
const str = `This is my first example string. {{foo}} This is what it looks like.
This is my second example string. {{1,2}}. This is what it looks like.
This is my third example string. {{a,b}} and {{2}}. This is`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}