import re
regex = re.compile(r"{{([^},]+)(?:,([^}]+))?}}")
test_str = ("This is my first example string. {{foo}} This is what it looks like.\n"
"This is my second example string. {{1,2}}. This is what it looks like.\n"
"This is my third example string. {{a,b}} and {{2}}. This is")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")