re = /{{([^},]+)(?:,([^}]+))?}}/
str = 'This is my first example string. {{foo}} This is what it looks like.
This is my second example string. {{1,2}}. This is what it looks like.
This is my third example string. {{a,b}} and {{2}}. This is'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end