package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s* \s*`)
var str = `18:30
18:20
17:30
18:30
17:58
18:00
19:00 18:41
18:00
19:00
18:12 19:00 21:00
20:11 20:00 21:00
20:56
21:00 22:00 21:33`
var substitution = "$0\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}