import re
regex = re.compile(r"\s* \s*", flags=re.MULTILINE)
test_str = ("18:30\n"
"18:20\n"
"17:30\n"
"18:30\n"
"17:58\n"
"18:00\n"
"19:00 18:41\n"
"18:00\n"
"19:00\n"
"18:12 19:00 21:00\n"
"20:11 20:00 21:00\n"
"20:56\n"
"21:00 22:00 21:33")
subst = "$0\\n"
result = regex.sub(subst, test_str)
if result:
print(result)