import Foundation
let pattern = #"\s* \s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
18:30
18:20
17:30
18:30
17:58
18:00
19:00 18:41
18:00
19:00
18:12 19:00 21:00
20:11 20:00 21:00
20:56
21:00 22:00 21:33
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)