use strict;
my $str = '18:30
18:20
17:30
18:30
17:58
18:00
19:00 18:41
18:00
19:00
18:12 19:00 21:00
20:11 20:00 21:00
20:56
21:00 22:00 21:33';
my $regex = qr/\s* \s*/mp;
my $subst = '$0\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";