import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([NSEW])?(-)?(\\d+(?:\\.\\d+)?)[°º:d\\s]\\s?(?:(\\d+(?:\\.\\d+)?)['’‘′:]\\s?(?:(\\d{1,2}(?:\\.\\d+)?)(?:\"|″|’’|'')?)?)?\\s?([NSEW])?";
final String string = "W59 12’ 70.7’’N 02 15’39.6’’N";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}