const regex = /^([NSEW])?(-)?(\d+(?:\.\d+)?)[°º:d\s]\s?(?:(\d+(?:\.\d+)?)['’‘′:]\s?(?:(\d{1,2}(?:\.\d+)?)(?:"|″|’’|'')?)?)?\s?([NSEW])?/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([NSEW])?(-)?(\\d+(?:\\.\\d+)?)[°º:d\\s]\\s?(?:(\\d+(?:\\.\\d+)?)[\'’‘′:]\\s?(?:(\\d{1,2}(?:\\.\\d+)?)(?:"|″|’’|\'\')?)?)?\\s?([NSEW])?', 'i')
const str = `W59 12’ 70.7’’N 02 15’39.6’’N`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}