re = /^([NSEW])?(-)?(\d+(?:\.\d+)?)[°º:d\s]\s?(?:(\d+(?:\.\d+)?)['’‘′:]\s?(?:(\d{1,2}(?:\.\d+)?)(?:"|″|’’|'')?)?)?\s?([NSEW])?/i
str = 'W59 12’ 70.7’’N 02 15’39.6’’N'
# Print the match result
str.match(re) do |match|
puts match.to_s
end