$re = '/^([NSEW])?(-)?(\d+(?:\.\d+)?)[°º:d\s]\s?(?:(\d+(?:\.\d+)?)[\'’‘′:]\s?(?:(\d{1,2}(?:\.\d+)?)(?:"|″|’’|\'\')?)?)?\s?([NSEW])?/i';
$str = 'W59 12’ 70.7’’N 02 15’39.6’’N';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);