using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+)\s(\S+)$";
string substitution = @"$2, $1";
string input = @"RENATa T. GROCHAL";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}