const regex = /(.+)\s(\S+)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+)\\s(\\S+)$', '')
const str = `RENATa T. GROCHAL`;
const subst = `$2, $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);