import re
regex = re.compile(r"(.+)\s(\S+)$")
test_str = "RENATa T. GROCHAL"
subst = "$2, $1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)