#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Section 11:)([.*\w\W\n]+)(?=Section 12:)"
Local $sString = "Section 11:" & @CRLF & _
"" & @CRLF & _
"Example text… 1 page and half mostly. " & @CRLF & _
"Test wording" & @CRLF & _
" Test wording" & @CRLF & _
"Section 12: "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")