$re = '/(?<=Section 11:)([.*\w\W\n]+)(?=Section 12:)/m';
$str = 'Section 11:
Example text… 1 page and half mostly.
Test wording
Test wording
Section 12: ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);