import re
regex = re.compile(r"(?<=Section 11:)([.*\w\W\n]+)(?=Section 12:)", flags=re.MULTILINE)
test_str = ("Section 11:\n\n"
"Example text… 1 page and half mostly. \n"
"Test wording\n"
" Test wording\n"
"Section 12: ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")