re = /(?<=Section 11:)([.*\w\W\n]+)(?=Section 12:)/m
str = 'Section 11:
Example text… 1 page and half mostly.
Test wording
Test wording
Section 12: '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end