const regex = /(?<=Section 11:)([.*\w\W\n]+)(?=Section 12:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Section 11:)([.*\\w\\W\\n]+)(?=Section 12:)', 'gm')
const str = `Section 11:
Example text… 1 page and half mostly.
Test wording
Test wording
Section 12: `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}