const regex = /\b(\d{2})_(\d{4})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d{2})_(\\d{4})\\b', 'gm')
const str = `02_2024.pdf`;
const subst = `$2_$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);