import Foundation
let pattern = #"\b(\d{2})_(\d{4})\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"02_2024.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2_$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)