$re = '/\b(\d{2})_(\d{4})\b/m';
$str = '02_2024.pdf';
$subst = "$2_$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;