using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<record[^>]*>\s*(.*?)\s*<\/record>";
string input = @" <record ID=""0"" dataID=""0x0"">
</record>
<record ID=""1"" dataID=""0x0"">
тут может быть всё,
что можетбыть напечатано
</record>
<record ID=""2"" dataID=""0x0"">
тут может быть всё, что может быть напечатано
</record>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}