package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<record[^>]*>\s*(.*?)\s*<\/record>`)
var str = ` <record ID="0" dataID="0x0">
</record>
<record ID="1" dataID="0x0">
тут может быть всё,
что можетбыть напечатано
</record>
<record ID="2" dataID="0x0">
тут может быть всё, что может быть напечатано
</record>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}