import Foundation
let pattern = #"<record[^>]*>\s*(.*?)\s*<\/record>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<record ID="0" dataID="0x0">
</record>
<record ID="1" dataID="0x0">
тут может быть всё,
что можетбыть напечатано
</record>
<record ID="2" dataID="0x0">
тут может быть всё, что может быть напечатано
</record>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)