const regex = new RegExp('<record[^>]*>\\s*(.*?)\\s*<\\/record>', 'gs')
const str = ` <record ID="0" dataID="0x0">
</record>
<record ID="1" dataID="0x0">
тут может быть всё,
что можетбыть напечатано
</record>
<record ID="2" dataID="0x0">
тут может быть всё, что может быть напечатано
</record>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}