use strict;
my $str = ' <record ID="0" dataID="0x0">
</record>
<record ID="1" dataID="0x0">
тут может быть всё,
что можетбыть напечатано
</record>
<record ID="2" dataID="0x0">
тут может быть всё, что может быть напечатано
</record>';
my $regex = qr/<record[^>]*>\s*(.*?)\s*<\/record>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}