package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`facture-[a-zA-Z\-9\-\.]+@masociete\.com`)
var str = `"toto@masociete.com,martine@orange.fr,facture-xxxx@masociete.com" ou "facture-xxxx@masociete.com"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}