// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"facture-[a-zA-Z\-9\-\.]+@masociete\.com").unwrap();
let string = "\"toto@masociete.com,martine@orange.fr,facture-xxxx@masociete.com\" ou \"facture-xxxx@masociete.com\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}