re = /facture-[a-zA-Z\-9\-\.]+@masociete\.com/
str = '"toto@masociete.com,martine@orange.fr,facture-xxxx@masociete.com" ou "facture-xxxx@masociete.com"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end