$re = '/facture-[a-zA-Z\-9\-\.]+@masociete\.com/';
$str = '"toto@masociete.com,martine@orange.fr,facture-xxxx@masociete.com" ou "facture-xxxx@masociete.com"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);