import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "facture-[a-zA-Z\\-9\\-\\.]+@masociete\\.com";
final String string = "\"toto@masociete.com,martine@orange.fr,facture-xxxx@masociete.com\" ou \"facture-xxxx@masociete.com\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}