# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=foo)bar/$1;$3;$5|$6|$9/;t' <<< "foobar fuubar"