$re = '/(?<=foo)bar/';
$str = 'foobar fuubar';
$subst = "$1;$3;$5|$6|$9";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;