const regex = /(?<=foo)bar/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=foo)bar', '')
const str = `foobar fuubar`;
const subst = `$1;$3;$5|$6|$9`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);