use strict;
my $str = 'foobar fuubar';
my $regex = qr/(?<=foo)bar/p;
my $subst = '$1;$3;$5|$6|$9';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";