using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=foo)bar";
string substitution = @"$1;$3;$5|$6|$9";
string input = @"foobar fuubar";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}