using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\w+|\W*?:\w+|\W*?)*\]";
string input = @"dfsdf[ewrwer:wer:sdfs:Sdfsds@#$@#$@3-sffsdf] werwe rwer [sdf-SDf:wsd:sdf] sdfsdf sdf [sdf-sf:sd sdf sd_f ewr12:3!@#f] sdf msdf
f sdf";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}