import Foundation
let pattern = #"\[(\w+|\W*?:\w+|\W*?)*\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
dfsdf[ewrwer:wer:sdfs:Sdfsds@#$@#$@3-sffsdf] werwe rwer [sdf-SDf:wsd:sdf] sdfsdf sdf [sdf-sf:sd sdf sd_f ewr12:3!@#f] sdf msdf
f sdf
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}