const regex = /\[(\w+|\W*?:\w+|\W*?)*\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(\\w+|\\W*?:\\w+|\\W*?)*\\]', '')
const str = `dfsdf[ewrwer:wer:sdfs:Sdfsds@#\$@#\$@3-sffsdf] werwe rwer [sdf-SDf:wsd:sdf] sdfsdf sdf [sdf-sf:sd sdf sd_f ewr12:3!@#f] sdf msdf
f sdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}