// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[(\w+|\W*?:\w+|\W*?)*\]").unwrap();
let string = "dfsdf[ewrwer:wer:sdfs:Sdfsds@#$@#$@3-sffsdf] werwe rwer [sdf-SDf:wsd:sdf] sdfsdf sdf [sdf-sf:sd sdf sd_f ewr12:3!@#f] sdf msdf
f sdf";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}