$re = '/\[(\w+|\W*?:\w+|\W*?)*\]/';
$str = 'dfsdf[ewrwer:wer:sdfs:Sdfsds@#$@#$@3-sffsdf] werwe rwer [sdf-SDf:wsd:sdf] sdfsdf sdf [sdf-sf:sd sdf sd_f ewr12:3!@#f] sdf msdf
f sdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);