import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(?=(?:.*type:([^/\\s]+))?)(?=(?:.*sort:([^/\\s]+))?).*";
final String string = "xbox/type:article/sort:date-desc\n"
+ "nintendo/type:media/sort:comments-asc\n"
+ "nintendo/type:1987/sort:14\n"
+ "pc/sort:views-desc\n"
+ "playstation/type:opinion/\n"
+ "playstation/sort:views-asc\n"
+ "xbox/sort:views-asc/type:article\n"
+ "playstation/type:media/sort:views-asc\n"
+ "xbox\n\n"
+ "02:52:00 P1D\n"
+ "y1987 m8 d13 02:52:00 P1D";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}