const regex = new RegExp('(?m)^(?=(?:.*type:([^/\\s]+))?)(?=(?:.*sort:([^/\\s]+))?).*', 'gm')
const str = `xbox/type:article/sort:date-desc
nintendo/type:media/sort:comments-asc
nintendo/type:1987/sort:14
pc/sort:views-desc
playstation/type:opinion/
playstation/sort:views-asc
xbox/sort:views-asc/type:article
playstation/type:media/sort:views-asc
xbox
02:52:00 P1D
y1987 m8 d13 02:52:00 P1D`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}