use strict;
my $str = 'xbox/type:article/sort:date-desc
nintendo/type:media/sort:comments-asc
nintendo/type:1987/sort:14
pc/sort:views-desc
playstation/type:opinion/
playstation/sort:views-asc
xbox/sort:views-asc/type:article
playstation/type:media/sort:views-asc
xbox
02:52:00 P1D
y1987 m8 d13 02:52:00 P1D';
my $regex = qr/(?m)^(?=(?:.*type:([^/\s]+))?)(?=(?:.*sort:([^/\s]+))?).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}