using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]{2,3}([-\/][a-zA-Z]{2,3})?$";
string input = @"XX
XXX
XX-XX
XXX-XX
XXX-XXX
XX-XXX
XX/XX
XXX/XX
XXX/XXX
XX/XXX";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}