$re = '/^[a-zA-Z]{2,3}([-\/][a-zA-Z]{2,3})?$/m';
$str = 'XX
XXX
XX-XX
XXX-XX
XXX-XXX
XX-XXX
XX/XX
XXX/XX
XXX/XXX
XX/XXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);